Announcement

Collapse
No announcement yet.

help w/Onix MFW-15 (woofer blown?)

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • help w/Onix MFW-15 (woofer blown?)

    I have two Onix 15" subs. One is sounding distorted....kinda like a blown woofer...

    Suggestions?

  • #2
    I've noticed where a lot of people are calling products Onix when they were obvisouly from a different company. I guess I don't blame them.

    Comment


    • #3
      Try here. http://www.audiocircle.com/index.php?topic=87767.0

      Or you could sell the AV123 MFW-15's and get some new subs. :eyebrows: http://www.chasehometheater.com/

      Comment


      • #4
        Hoots

        Long time since I have seen you around on the boards....

        I doubt its the woofer, but danny at GR Research has those if it is. Have you tried pushing it in to see if the voice coil is bad?

        I would guess its a bad amp since they are failing like crazy. You could pull the amp and check the caps to see if they are swollen and bad. You can find more info over at avs http://www.avsforum.com/avs-vb/showp...postcount=1195

        I am also working with Mark Seaton on a few things for this sub, the Turbo Kit that is a new driver and external amp (2X the output with better sound quality) that is available now. We are also working on a drop in amp and a improved replacement driver.

        Kevin

        Originally posted by Hoots
        I have two Onix 15" subs. One is sounding distorted....kinda like a blown woofer...

        Suggestions?
        Kevin
        Motor City Custom Audio
        Your Onix and MELODY Dealer for MI,IN,IL,MO,IA,MN,WI and Canada
        Bringing you Chopped/Cut/Modified Subwoofer Kits and even Flames if you want

        Comment


        • #5
          Thanks.... I guess I need to pull the amp board to see if that is the problem.
          I saw the 4 cap swap instructions...thx

          I pushed the driver in...it moves back and forth without noise or problems

          Seems like I have options.


          Yes, I got the brand wrong...my speakers are Onix from AV123 and these are AV123 subs.

          Comment


          • #6
            Sounds like the driver is still good

            If you have any questions on the cap fix let me know as I have done a few

            Originally posted by Hoots
            Thanks.... I guess I need to pull the amp board to see if that is the problem.
            I saw the 4 cap swap instructions...thx

            I pushed the driver in...it moves back and forth without noise or problems

            Seems like I have options.


            Yes, I got the brand wrong...my speakers are Onix from AV123 and these are AV123 subs.
            Kevin
            Motor City Custom Audio
            Your Onix and MELODY Dealer for MI,IN,IL,MO,IA,MN,WI and Canada
            Bringing you Chopped/Cut/Modified Subwoofer Kits and even Flames if you want

            Comment

            Working...
            X