Announcement

Collapse
No announcement yet.

Please help with ULW-10 :)

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Please help with ULW-10 :)

    Hey gang,

    Some of you may remember me from AV123 as I used to be a fanboy over there. Anyway, 2.5 years after ordering, I have a ULW-10 in my living room. I first received the 500 watt amp, which quickly went bad, and I sent it back.

    Before it died, I was reasonably pleased. Tight bass with some impact.

    It was recently returned to me with this amp installed:

    http://www.parts-express.com/pe/show...number=300-804

    I am powering this all with an Onkyo 707. I calibrated the system using the 6 point audyssey MultiEQ setup. Initial setup had set the crossover at 60 hz, which I bumped up to 80, and had set the sub level very low, which I boosted.

    I can barely hear the bass, and it has no impact. If I turn up the gain, it just gets distorted and sounds terrible. I am at a loss and would love some advice.

    I feel like a fool for waiting all these years without a sub and am now stuck with this thing. Is it the low quality amp? Something I'm doing wrong in setup? There isnt even an LFE input anymore.

    Thanks :)

    My fronts are a pair of X-SLS and an X-CS which are currently being ninjafied and should be done next week.

  • #2
    You might check with the Motor City Custom Audio (sub-)forum (at Seaton Sound Forum):

    Link

    I don't know about ULW-10, but they do UFW-10 replacements.
    Sandbagger also is on TCA.


    Mike
    HT Gear (AVS Link)
    Rk: MA WR-37-32
    Pwr: 20A, Surge-X SEQ, M1500-UPS
    Proj: JVC RS20, 128" 2.4:1 CaradaBW, ISCOIIIL, CineSlide, RadianceXE
    Cbl: DirectTV C31/700 Genie receiver
    Rec: 5308CI + XPA-3
    BR: Oppo BDP-103
    Gm: 360 Pro
    LR/C: RS1KSig/RSC200Sig
    S/R: RSS300/RS250MkII
    Sub: SVS PB12-Ultra/2
    Off: HRT MS DAC, USP-1, UPA-2, ERC-1, Ultra10, WAF-1 Ninja+No-Rez
    Off2: Gizmo, WAF-1
    TCA: 3x Gizmo 1.0or,5x v1.0M; 5xWAF-1

    Comment


    • #3
      The ULW and UFW are the same sub, just different cabinets. I really don't wanna sink any more money into this thing :(

      Comment


      • #4
        Originally posted by Mavinwow
        The ULW and UFW are the same sub, just different cabinets. I really don't wanna sink any more money into this thing :(
        I would pick Sandbagger's brain as he has been working on these.
        I'm not sure what the options would be, but I don't think you are alone in your problems with it.

        Mike
        HT Gear (AVS Link)
        Rk: MA WR-37-32
        Pwr: 20A, Surge-X SEQ, M1500-UPS
        Proj: JVC RS20, 128" 2.4:1 CaradaBW, ISCOIIIL, CineSlide, RadianceXE
        Cbl: DirectTV C31/700 Genie receiver
        Rec: 5308CI + XPA-3
        BR: Oppo BDP-103
        Gm: 360 Pro
        LR/C: RS1KSig/RSC200Sig
        S/R: RSS300/RS250MkII
        Sub: SVS PB12-Ultra/2
        Off: HRT MS DAC, USP-1, UPA-2, ERC-1, Ultra10, WAF-1 Ninja+No-Rez
        Off2: Gizmo, WAF-1
        TCA: 3x Gizmo 1.0or,5x v1.0M; 5xWAF-1

        Comment


        • #5
          Yeah, my ULW-10 broke and sat dormant for two years before I finally got the 500 watt replacement amp. That broke a few weeks ago and now its just a doorstop. Like you, I don't want to put any more money into it and the reports of the new amp sound really underwhelming. I can't believe I paid $900 for this thing...

          Its too bad because the small window it did work, it was a very impressive little sub. Good luck finding a solution.

          Comment


          • #6
            Thanks for the reply Jed. I feel pretty screwed with this whole thing. Sounds like you think its the sub/amp and not my setup?

            Can you point me to the thread with the underwhelming performance talk?

            Such a waste of time/money/effort on this stupid thing.

            Comment


            • #7
              Originally posted by Mavinwow
              Thanks for the reply Jed. I feel pretty screwed with this whole thing. Sounds like you think its the sub/amp and not my setup?

              Can you point me to the thread with the underwhelming performance talk?

              Such a waste of time/money/effort on this stupid thing.
              Luckily, some new budget friendly amps are due out soon...
              "thumbsup:


              Mike
              HT Gear (AVS Link)
              Rk: MA WR-37-32
              Pwr: 20A, Surge-X SEQ, M1500-UPS
              Proj: JVC RS20, 128" 2.4:1 CaradaBW, ISCOIIIL, CineSlide, RadianceXE
              Cbl: DirectTV C31/700 Genie receiver
              Rec: 5308CI + XPA-3
              BR: Oppo BDP-103
              Gm: 360 Pro
              LR/C: RS1KSig/RSC200Sig
              S/R: RSS300/RS250MkII
              Sub: SVS PB12-Ultra/2
              Off: HRT MS DAC, USP-1, UPA-2, ERC-1, Ultra10, WAF-1 Ninja+No-Rez
              Off2: Gizmo, WAF-1
              TCA: 3x Gizmo 1.0or,5x v1.0M; 5xWAF-1

              Comment


              • #8
                The mod Kevin is selling is for the UFW-12, and it involves putting a 15" driver in it. I'm not sure if he's thought at all about the 10's or not, but there's definitely not something imminent.

                I sold my ULW-10 immediately upon receiving it back with the PE amp. Didn't even plug it in. I was pretty irritated with the whole thing.
                Angel City Audio
                East Street Audio

                ACA, Melody, Onix, NuForce, KR Audio

                Comment


                • #9
                  Originally posted by Mavinwow
                  Thanks for the reply Jed. I feel pretty screwed with this whole thing. Sounds like you think its the sub/amp and not my setup?

                  Can you point me to the thread with the underwhelming performance talk?

                  Such a waste of time/money/effort on this stupid thing.
                  http://forums.av123.com/showpost.php...2&postcount=58

                  http://forums.av123.com/showpost.php...7&postcount=66

                  http://forums.av123.com/showpost.php...0&postcount=96

                  Found in this thread.
                  http://forums.av123.com/showthread.p...=parts+express
                  I realize I quoted the same guy twice. The thread sheds more light on the amp though.

                  One thing you may want to try is one poster claims that he got an amazing difference in output when he used a splitter and connected both inputs, but nobody else reported getting those results. There are also scattered posts here and AH and AVS but you get the idea. No different than the last ditch scraps they threw together for the HR kit. It is what is is I guess.

                  Comment


                  • #10
                    Originally posted by woofersus
                    The mod Kevin is selling is for the UFW-12, and it involves putting a 15" driver in it. I'm not sure if he's thought at all about the 10's or not, but there's definitely not something imminent.

                    I sold my ULW-10 immediately upon receiving it back with the PE amp. Didn't even plug it in. I was pretty irritated with the whole thing.
                    Ahh.
                    My mistake, I thought there were two threads/mods.

                    Mike
                    HT Gear (AVS Link)
                    Rk: MA WR-37-32
                    Pwr: 20A, Surge-X SEQ, M1500-UPS
                    Proj: JVC RS20, 128" 2.4:1 CaradaBW, ISCOIIIL, CineSlide, RadianceXE
                    Cbl: DirectTV C31/700 Genie receiver
                    Rec: 5308CI + XPA-3
                    BR: Oppo BDP-103
                    Gm: 360 Pro
                    LR/C: RS1KSig/RSC200Sig
                    S/R: RSS300/RS250MkII
                    Sub: SVS PB12-Ultra/2
                    Off: HRT MS DAC, USP-1, UPA-2, ERC-1, Ultra10, WAF-1 Ninja+No-Rez
                    Off2: Gizmo, WAF-1
                    TCA: 3x Gizmo 1.0or,5x v1.0M; 5xWAF-1

                    Comment


                    • #11
                      If anyone finds a better amp to use, let us know. I bought a UFW10 brand new a few years back and it made terrible noises....waited years for a replacement and this is what I got (the PE amp)
                      It won't make much bass but it should be reliable...if that counts for anything.

                      People were claiming great results from the 500+ watt early replacement amps, so I do wonder what could be done.
                      "Sometimes I think the surest sign that intelligent life exists elsewhere in the universe is that none of it has tried to contact us."

                      -Bill Watterson

                      Comment


                      • #12
                        Originally posted by Cujobob
                        If anyone finds a better amp to use, let us know. I bought a UFW10 brand new a few years back and it made terrible noises....waited years for a replacement and this is what I got (the PE amp)
                        It won't make much bass but it should be reliable...if that counts for anything.

                        People were claiming great results from the 500+ watt early replacement amps, so I do wonder what could be done.
                        Yeah, the replacement 500w amps were really tremendous. Too bad they have proved unreliable, but I remember thinking how much I hoped they came out with that sub again because I would have had all my friends get one. Dodged a bullet there...

                        Like I said, I have no intentions of getting the new amp, but you are right, at bare minimum it should be reliable and easy to replace if something does go wrong.

                        Comment


                        • #13
                          Hey guys

                          Yes I do have 2 upgrade kits out right now, well ok one should be in 2 or so weeks but they are for the UFW-12 and the MFW-15. More info can be found over here http://www.seaton-sound-forum.com/?forum=154357 on Mr. Seatons forum

                          There has been some discussion around the posibility of doing something with the UFW/L-10. I dont own one and nor does anyone I know( but sounds like Cujo has one). While it is probably #3 or #4 on the list of projects for me, it is something I might consider looking into if there is enough interest.
                          Kevin
                          Motor City Custom Audio
                          Your Onix and MELODY Dealer for MI,IN,IL,MO,IA,MN,WI and Canada
                          Bringing you Chopped/Cut/Modified Subwoofer Kits and even Flames if you want

                          Comment


                          • #14
                            What is the statute of limitations on challenging credit card charges?

                            I feel totally hosed on this. Bah.

                            I was hoping it was a setup thing on my end.

                            Comment


                            • #15
                              It is pretty short, I think you have 30 or 60 days, but give your credit card company a call they might be able to help you out. It is also usually pretty cheap to file a claim in small claims court. Don't expect that you would be able to get something out of them, but it might make you feel better.
                              Probably all it needs is a higher power amp...
                              Originally posted by Mavinwow
                              What is the statute of limitations on challenging credit card charges?

                              I feel totally hosed on this. Bah.

                              I was hoping it was a setup thing on my end.

                              Comment

                              Working...
                              X